注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

实施OSPF和DHCP中继代理综合实验  

2017-03-03 12:56:39|  分类: 安德的技术文章 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

心有所止,怀奋斗之心

愿万里归来,仍是少年 

一、实验说明

实验目的:1、了解实施OSPFDHCP中继代理

 设备需求:路由器2台、交换机2台、路由器模拟PC 3

实验要求:1、按照拓扑图连接好设备以及按拓扑图配置IP地址

2、在BranchHQ实施OSPF进程1,使得各自的网络可以通信,并将连接终端的接口配置passive

3、在实施完毕OSPF的情况下,把DHCP服务割接到HQ,在Branch完成DHCP

二、实验拓扑图(附端口 IP地址对照表)

实施OSPF和DHCP中继代理综合实验 - ender.joe - 乾颐堂_安德(Ender)的博客

 

拓扑图

 

三、实验步骤及主要配置命令

1.对拓扑图中网络设备进行基本配置

(1)对路由器Branch进行如下配置:

Router>                                             //用户模式

Router>enable                                        //进入特权模式

Router#configure terminal                              //进入配置模式

Router(config)#hostname Branch                        //设备命名为Branch

Branch(config)#interface ethernet 0/1                     //进入ethernet 0/1

Branch(config-if)#no shutdown                          //开启ethernet 0/1

Branch(config-if)#ip address 192.168.1.1 255.255.255.0      //ethernet 0/1口配置IP地址

Branch(config-if)# interface serial 1/0                     //进入serial 1/0

Branch(config-if)#no shutdown                          //开启serial 1/0

Branch(config-if)#ip address 202.100.1.1 255.255.255.0      //serial 1/0口配置IP地址

Branch(config-if)# interface ethernet 0/0                  //进入ethernet 0/0

Branch(config-if)#no shutdown                         //开启ethernet 0/0

Branch(config-if)#interface ethernet 0/0.1                 //进入子接口ethernet 0/0.1

Branch(config-subif)#encapsulation dot1Q 10            //通过子接口封装DOT1Q来识别vlan10的流量

Branch(config-subif)#ip address 10.1.10.254 255.255.255.0  //为子接口ethernet 0/0.1配置IP地址

Branch(config-subif)#interface ethernet 0/0.2              //进入子接口ethernet 0/0.2

Branch(config-subif)#encapsulation dot1Q 20            //通过子接口封装DOT1Q来识别vlan20的流量

Branch(config-subif)#ip address 10.1.20.254 255.255.255.0  // 为子接口ethernet 0/0.2配置IP地址

Branch(config-subif)#end                             //返回特权模式

Branch#show ip interface brief                     //查看端口信息,验证IP地址是否配置正确

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                unassigned      YES unset  up                    up     

Ethernet0/0.1              10.1.10.254     YES manual up                    up     

Ethernet0/0.2              10.1.20.254     YES manual up                    up     

Ethernet0/1                192.168.1.1     YES manual up                    up     

Serial1/0                  202.100.1.1     YES manual up                    down   


Branch#

 

(2)对路由器HQ进行如下配置:

Router>                                         //用户模式

Router>enable                                    //进入特权模式

Router#configure terminal                           //进入配置模式

Router(config)#hostname HQ                        //将设备命名为HQ

HQ(config)#interface ethernet 0/1                     //进入ethernet 0/1

HQ(config-if)#no shutdown                          //开启ethernet 0/1

HQ(config-if)#ip address 192.168.1.2 255.255.255.0      //为接口ethernet 0/1配置IP地址

HQ(config-if)#interface serial 1/0                     //进入serial 1/0

HQ(config-if)#no shutdown                          //开启serial 1/0

HQ(config-if)#ip address 202.100.1.2 255.255.255.0      //为接口serial 1/0配置IP地址

HQ(config-if)#interface ethernet 0/0                   //进入ethernet 0/0

HQ(config-if)#no shutdown                          //开启ethernet 0/0

HQ(config-if)#ip address 172.16.1.254 255.255.255.0     //为接口ethernet 0/0配置IP地址

HQ(config-if)#end                                 //返回特权模式

HQ#show ip interface brief                        //查看端口信息,验证IP地址是否配置正确

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                172.16.1.254    YES manual up                    up     

Ethernet0/1                192.168.1.2     YES manual up                    up     

Ethernet0/2                unassigned      YES unset  administratively down down   

Ethernet0/3                unassigned      YES unset  administratively down down   

Serial1/0                  202.100.1.2     YES manual up                    up     


 

HQ#ping 192.168.1.1 source 192.168.1.2              //测试BranchHQ之间E0/1之间连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

HQ#ping 202.100.1.1 source 202.100.1.2              //测试BranchHQ之间S1/0之间连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 202.100.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 9/10/11 ms

HQ#

 

3)对交换机SW1进行如下配置:

Switch>                                              //用户模式

Switch>enable                                         //进入特权模式

Switch#configure terminal                               //进入配置模式

Switch(config)#hostname SW1                           //将设备命名为SW1

SW1(config)#vlan 10,20                                //创建vlan10vlan20

SW1(config-vlan)#exit                                 //返回配置模式

SW1(config)#interface ethernet 0/1                       //进入ethernet 0/1

SW1(config-if)#switchport mode access                   //ethernet 0/1口配置为access模式

SW1(config-if)#switchport access vlan 10                  //将端口ethernet 0/1划分到vlan10

SW1(config-if)# interface range ethernet 0/2 -3              //进入ethernet 0/2ethernet 0/3

SW1(config-if-range)#switchport trunk encapsulation dot1q    //手工封装dot1q模式

SW1(config-if-range)#switchport mode trunk                //将交换机端口配置为trunk模式

SW1(config-if-range)#exit                               //返回配置模式

SW1(config)#interface ethernet 0/0                        //进入ethernet 0/0

SW1(config-if)#switchport trunk encapsulation dot1q         //手工封装dot1q模式

SW1(config-if)#switchport mode trunk                     //将交换机端口配置为trunk模式

SW1(config-if)#end                                    //返回特权模式

SW1#show interfaces ethernet 0/1 switchport                //查看ethernet 0/1口交换信息

Name: Et0/1

Switchport: Enabled

Administrative Mode: static access                         //管理模式为access

Operational Mode: static access                           //操作模式为access

Negotiation of Trunking: Off

Access Mode VLAN: 10 (VLAN0010)                     //该接口被划分在vlan10

(4)SW2进行如下配置:

Switch>                                           //用户模式

Switch>enable                                      //进入特权模式

Switch#configure terminal                             //进入配置模式

Switch(config)#hostname SW2                         //将设备命名为SW2

SW2(config)#vlan 20                                 //创建vlan20

SW2(config-vlan)#exit                                //返回配置模式

SW2(config)#interface ethernet 0/1                      //进入ethernet 0/1

SW2(config-if)#switchport mode access                  //ethernet 0/1口配置为access模式

SW2(config-if)#switchport access vlan 20                 //将端口ethernet 0/1划分到vlan20

SW2(config-if)#interface range ethernet 0/2 -3             //进入ethernet 0/2ethernet 0/3

SW2(config-if-range)#switchport trunk encapsulation dot1q  //手工封装dot1q模式

SW2(config-if-range)#switchport mode trunk              //将交换机端口配置为trunk模式

5)对路由器模拟的PC1进行如下配置:

Router>                                         //用户模式

Router>enable                                    //进入特权模式

Router#configure terminal                          //进入配置模式

Router(config)#hostname PC1                       //将设备命名为PC1

PC1(config)#interface ethernet 0/1                   //进入接口ethernet 0/1

PC1(config-if)#ip address 10.1.10.100 255.255.255.0    //为接口ethernet 0/1配置1IP地址

PC1(config-if)#no shutdown                        //开启接口ethernet 0/1

PC1(config-if)#exit                               //返回到配置模式

PC1(config)#no ip routing                         //关闭路由器路由功能

PC1(config)#ip default-gateway 10.1.10.254          //为路由器模拟的PC配置默认网关

PC1(config)#end                                //返回到特权模式

PC1#show ip route                               //查看路由表

Default gateway is 10.1.10.254                     //所有去往非本网络的数据都发往了该地址

 

(6)对路由器模拟的PC2进行如下配置:

Router>                                        //用户模式

Router>enable                                   //进入特权模式

Router#configure terminal                         //进入配置模式

Router(config)#hostname PC2                      //将设备命名为PC2

PC2(config)#interface ethernet 0/1                  //进入接口ethernet 0/1

PC2(config-if)#no shutdown                       //开启接口ethernet 0/1

PC2(config-if)#ip address 10.1.20.100 255.255.255.0   //为接口ethernet 0/1配置1IP地址

PC2(config)#no ip routing                        //关闭路由器路由功能

PC2(config)#ip default-gateway 10.1.20.254          //为路由器模拟的PC配置默认网关

PC2(config)#end                                //返回到特权模式

PC2#show ip route                               //查看路由表

Default gateway is 10.1.20.254                     //所有去往非本网络的数据都发往了该地址

 

Host               Gateway           Last Use    Total Uses  Interface

ICMP redirect cache is empty

PC2#

PC2#ping 10.1.20.254                            //测试PC2到网关连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.20.254, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/201/1003 ms

PC2#ping 10.1.10.254                            //测试PC2PC1网关连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.10.254, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

PC2#ping 10.1.10.100                             //测试PC2PC1的连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.10.100, timeout is 2 seconds:

.!!!!

Success rate is 80 percent (4/5), round-trip min/avg/max = 1/3/9 ms

PC2#

 

7)对路由器模拟Server进行如下配置:

Router>                                          //用户模式

Router>enable                                     //进入特权模式

Router#configure terminal                           //进入配置配置

Router(config)#hostname Server                      //将设备命名为Server

Server(config)#interface ethernet 0/0                   //进入ethernet 0/0

Server(config-if)#no shutdown                        //开启ethernet 0/0

Server(config-if)#ip address 172.16.1.1 255.255.255.0     //ethernet 0/0口配置IP地址

Server(config-if)#exit                               //返回配置模式

Server(config)#no ip routing                          //关闭路由器路由功能

Server(config)#ip default-gateway 172.16.1.254          //为路由器模拟的PC配置默认网关

Server(config)#end                                 //返回特权模式

Server#show ip route                               //查看路由表

Default gateway is 172.16.1.254                    //所有去往非本网络的数据都发往了该地址

Server#ping 172.16.1.254                           //测试Server到网关的连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.254, timeout is 2 seconds:

!!!!!

2BranchHQ实施OSPF进程1,使得各自的网络可以通信,并将连接终端的接口配置passive

(1)Branch进行如下配置:

Branch#configure terminal                      //进入配置模式

Branch(config)#router ospf 1                    //建立OSPF进程1

Branch(config-router)#router-id 1.1.1.1            //IPv4地址格式出现的RID,每个设备的每个OSPF进程必须唯一

Branch(config-router)#passive-interface e0/0        //抑制E0/0口不发送Hello报文

Branch(config-router)#exit                      //返回配置模式

Branch(config)#interface ethernet 0/1              //进入ethernet 0/1

Branch(config-if)#ip ospf 1 area 0                //该接口激活了OSPF进程,发送Hello尝试建立邻居;把该接口的网络通告到OSPF,以便邻居学习到

Branch(config-if)#interface ethernet 0/0.1           //进入子接口ethernet 0/0.1

Branch(config-subif)#ip ospf 1 area 0              //该接口激活了OSPF进程,发送Hello尝试建立邻居;把该接口的网络通告到OSPF,以便邻居学习到

Branch(config-subif)#interface ethernet 0/0.2         //进入子接口ethernet 0/0.2

Branch(config-subif)#ip ospf 1 area 1                //该接口激活了OSPF进程,发送Hello尝试建立邻居;把该接口的网络通告到OSPF,以便邻居学习到

Branch(config-subif)#end                         //返回特权模式

2)对路由器HQ进行如下配置:

HQ#                                            //用户模式

HQ#configure terminal                             //进入配置模式

HQ(config)#router ospf 1                           //建立OSPF进程1

HQ(config-router)#router-id 2.2.2.2                   //IPv4地址格式出现的RID,每个设备的每个OSPF进程必须唯一

HQ(config-router)#passive-interface e0/0               //抑制E0/0口不发送Hello报文

HQ(config-router)#exit                             //返回配置模式

HQ(config)#interface ethernet 0/1                    //进入ethernet 0/1

HQ(config-if)#ip ospf 1 area 0                       //该接口激活了OSPF进程,发送Hello尝试建立邻居;把该接口的网络通告到OSPF,以便邻居学习到

HQ(config-if)#exit                                  //返回配置模式

HQ(config)#router ospf 1                            //进入OSPF进程1

HQ(config-router)#network 172.16.1.0 0.0.0.255 area 1   //使用通配符掩码来通告某个范围的路由以及激活该范围内的接口运行OSPF

HQ(config-router)#end                             //返回特权模式

HQ#sho ip route ospf                              //查看OSPF路由表

O        10.1.10.0 [110/20] via 192.168.1.1, 00:00:25, Ethernet0/1    //区域内路由

O IA     10.1.20.0 [110/20] via 192.168.1.1, 00:00:25, Ethernet0/1     //区域间路由

HQ#show ip ospf neighbor                                  //查看OSPF邻居表

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1           1   FULL/DR         00:00:31    192.168.1.1     Ethernet0/1

(3)测试PC1ServerPC2Server的连通性

PC1#ping 172.16.1.1                       //PC1Server的连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/2 ms

PC1#

PC2#ping 172.16.1.1                       //PC2Server的连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

3、在实施完毕OSPF的情况下,把DHCP服务割接到HQ,在Branch完成DHCP中继

1)对HQ进行如下配置:

HQ#configure terminal                     //进入配置模式

HQ (config)#ip dhcp excluded-address 10.1.10.101 10.1.10.254  //指定10.1.10.101~254不参与自动分配

HQ (config)#ip dhcp excluded-address 10.1.20.101 10.1.20.254   //指定10.1.20.101~254不参与自动分配

HQ (config)#ip dhcp pool VLAN10-CCNA     //配置DHCP地址池的名字

HQ (dhcp-config)#network 10.1.10.0 /24       //为客户端分配10.1.10.0 /24的网段地址

HQ (dhcp-config)#default-router 10.1.10.254   //为客户端分配默认网关

HQ (dhcp-config)#dns-server 114.114.114.114  //为客户端分配DNS服务器地址

HQ (dhcp-config)#lease 1 16                //配置IP地址的租期为116小时

HQ (dhcp-config)#exi                      //返回配置模式

HQ (config)#ip dhcp excluded-address 10.1.10.101 10.1.10.254  //指定10.1.10.101~254不参与自动分配

HQ (config)#ip dhcp pool VLAN20-CCNA     //配置DHCP地址池的名字

HQ (dhcp-config)#network  10.1.20.0 /24      //为客户端分配10.1.20.0 /24的网段地址

HQ (dhcp-config)#default-router 10.1.20.254    //为客户端分配10.1.10.0 /24的网段地址

HQ (dhcp-config)#dns-server 114.114.114.254   //为客户端分配DNS服务器地址

HQ (dhcp-config)#lease 1 16                 //配置IP地址的租期为116小时

HQ (config)#ip dhcp excluded-address 10.1.20.101 10.1.20.254   //指定10.1.20.101~254不参与自动分配

(2)Branch进行如下配置:

Branch#                                          //特权模式

Branch#configure terminal                           //进入配置模式

Branch(config)#interface ethernet 0/0.1                 //进入子接口ethernet 0/0.1

Branch(config-subif)#ip helper-address 172.16.1.254      //指定DHCP服务器地址

Branch(config-subif)# interface ethernet 0/0.2            //进入子接口ethernet 0/0.2

Branch(config-subif)#ip helper-address 172.16.1.254      //指定DHCP服务器地址

 (3)PC1进行如下配置:

PC1#configure terminal                                //进入配置模式

PC1(config)#interface ethernet 0/1                       //进入ethernet 0/1

PC1(config-if)#shutdown                              //关闭ethernet 0/1

PC1(config-if)#no shutdown                            //开启ethernet 0/1

PC1(config-if)#ip address dhcp                         //接口IP地址通过DHCP获取

PC1(config-if)#end                                   //返回特权模式

PC1#show ip interface brief                            //查看端口信息

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                unassigned      YES unset  administratively down down   

Ethernet0/1                10.1.10.1       YES DHCP   up                    up     

(4)PC2进行如下配置:

PC2#configure terminal                          //进入配置模式

PC2(config)#interface ethernet 0/1                 //进入ethernet 0/1

PC2(config-if)#shutdown                        //关闭ethernet 0/1

PC2(config-if)#no shutdown                     //开启ethernet 0/1

PC2(config-if)#ip address dhcp                   //接口IP地址通过DHCP获取

PC2(config-if)#end                             //返回特权模式

PC2#show ip interface brief                      //查看端口信息

Interface                  IP-Address      OK? Method Status                Protocol

Ethernet0/0                unassigned      YES unset  administratively down down   

Ethernet0/1                10.1.20.1       YES DHCP   up                    up     

(5)测试PC1PC2PC1Server的连通性

PC1#ping 10.1.20.1                //测试PC1PC3连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.20.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

PC1#ping 172.16.1.1              //测试PC1Server连通性

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/202/1005 ms

PC1

  评论这张
 
阅读(131)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017