注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

在交换机之间实施ACCESS以及TRUNK使得不同vlan之间可以通信  

2017-02-24 18:10:39|  分类: 初级阶段课程 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
拓扑如下:
在交换机之间实施ACCESS以及TRUNK使得不同vlan之间可以通信 - ender.joe - 乾颐堂_安德(Ender)的博客
  一.ACCESS的独享模式
SW1和SW2交换机之间的链路access到vlan10,sw1和2的e0/1 acces到vlan10

 分别给pc1 pc2 一个同网段IP地址
pc1>
pc1>en
pc1#conf t 
Enter configuration commands, one per line.  End with CNTL/Z.
pc1(config)#no ip routing   关闭路由功能
pc1(config)#ip default-gateway 10.1.10.254  设置网关
pc1(config)#int e0/1
pc1(config-if)#ip address 10.1.10.100 255.255.255.0  设置IP地址
pc1(config-if)#no sh 开启接口

PC2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
PC2(config)#no ip routing    关闭路由功能
PC2(config)#ip default-gateway 10.1.10.254   设置网关
PC2(config)#interface  e0/1
PC2(config-if)#ip address 10.1.10.200 255.255.255.0  设置IP地址
PC2(config-if)#no sh   开启接口

在sw1创建vlan10  并把 e0/1 - 2划分到vlan10
sw1>en
sw1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
sw1(config)#vlan 10  创建vlan10
sw1(config-vlan)#exit 
sw1(config)#interface range e0/1 - 2  同时进入e0/1 - 2 
sw1(config-if-range)#switchport mode access     将接口设置为access 
sw1(config-if-range)#switchport access vlan 10     将接口划分到vlan10
sw1(config-if-range)#^Z

sw1#sh vlan brief 查看vlan简要信息

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/0, Et1/0, Et1/1, Et1/2
                                                Et1/3, Et2/0, Et2/1, Et2/2
                                                Et2/3
10   VLAN0010                         active    Et0/1, Et0/2
1002 fddi-default            

在sw2上创建vlan10  并把 e0/1 - 2划分到vlan10

sw2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
sw2(config)#vlan 10   创建vlan10
sw2(config-vlan)#exit
sw2(config)#interface range e0/1 - 2 同时进入e0/1 - 2 
sw2(config-if-range)#sw mo access  将接口设置为access 
sw2(config-if-range)#sw acc vlan 10  将接口划分到vlan10
sw2#sh vlan b   查看vlan简要信息

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Et0/0, Et1/0, Et1/1, Et1/2
                                                Et1/3, Et2/0, Et2/1, Et2/2
                                                Et2/3
10   VLAN0010                         active    Et0/1, Et0/2
1002 fddi-default                     act/unsup 
1003 token-ring-default               act/unsup 
1004 fddinet-default                  act/unsup 
1005 trnet-default                    act/unsup 
sw2#

连通测试
pc1#ping 10.1.10.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.10.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/5 ms
pc1#ping 10.1.10.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.10.200, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/2 ms
pc1#

二、在交换机之间的TRUNK模式时修改本征vlan,使得同一广播域的IP通信
PC1(10.1.10.100)---SW1(本10)----TRUNK----(本100)SW2---PC2(10.1.10.200)
不同vlan ID的通信

sw1#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
sw1(config)#interface e0/1
sw1(config-if)#switchport mode access  将接口设置为access 模式
sw1(config-if)#switchport access vlan 10  将接口划分到vlan10
sw1(config-if)#ex    
sw1(config)#int e0/2
sw1(config-if)#switchport trunk encapsulation dot1q  trunk链路封装为dot1q
w1(config-if)#switchport mode trunk 将接口设置为trunk 模式
sw1(config-if)#switchport access vlan 10   将接口划分到vlan10
sw1(config-if)#switchport trunk native vlan 10  本征vlan为10

sw1#sh int trunk   查看vlan简要信息
Port        Mode             Encapsulation  Status        Native vlan
Et0/2       on               802.1q         trunking      10
Et0/3       desirable        n-isl          trunking      1

Port        Vlans allowed on trunk
Et0/2       1-4094
Et0/3       1-4094

Port        Vlans allowed and active in management domain
Et0/2       1,10
Et0/3       1,10

Port        Vlans in spanning tree forwarding state and not pruned
Et0/2       1,10
Et0/3       1,10
sw1#


sw2#
sw2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
sw2(config)#vlan 100  创建vlan100
sw2(config-vlan)#ex
sw2(config)#interface e0/2
sw2(config-if)#switchport trunk encapsulation d trunk链路封装为dot1q
sw2(config-if)#sw mo trunk     trunk链路封装为dot1q
sw2(config-if)#switchport access vlan 100  将接口划分到vlan100
sw2(config-if)#switchport trunk native vlan 100  本征vlan为100
sw2(config-if)#
*Feb 23 04:50:35.274: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on Ethernet0/2 (100), with sw1 Ethernet0/2 (10).
sw2(config-if)#

sw2#sh int trunk   查看vlan简要信息
Port        Mode             Encapsulation  Status        Native vlan
Et0/2       on               802.1q         trunking      100
Et0/3       desirable        n-isl          trunking      1

Port        Vlans allowed on trunk
Et0/2       1-4094
Et0/3       1-4094

连通性测试
pc1#ping 10.1.10.100
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.10.100, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 5/5/5 ms
pc1#ping 10.1.10.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.10.200, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
pc1#
  评论这张
 
阅读(172)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017