注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

IOS XR实现SP CCIEv4.0的6PE和6VPE  

2016-06-21 21:46:14|  分类: IOS XR-IOX系列 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
1.6PE
实施6PE
1.1 域内的IGP和LDP

1.2 PE上的接口属于全局而非VRF
interface GigabitEthernet0/1
 ip vrf forwarding QYT
 ip address 56.1.1.6 255.255.255.0
 ipv6 address 2056::6/64
 ipv6 rip Ender enable //该接口属于全局而非VRF
XR上出现的问题:该接口不能IPv4属于VRF而IPv6属于全局
IOS上IPv4可以属于vrf而IPv6属于全局
router ospfv3 Ender
 area 0
  interface GigabitEthernet0/0/0/1 //通告接口
PE上已经通过全局得到了客户的路由

1.3 多协议BGP的配置
BGP对IPv6单播的支持
BGP对IPv6单播路由分发标签的能力
router bgp 100
 address-family ipv6 unicast
  redistribute ospfv3 Ender
  allocate-label all //对所有IPv6单播路由分发标签并且批量更新
 address-family ipv6
  neighbor 22.1.1.1 activate
  neighbor 22.1.1.1 send-label //在IPv6地址族针对IPv4地址激活新的针对Ipv6单播路由分发标签的能力

1.4 双向重分步
router ospfv3 Ender
 redistribute bgp 100
!
router bgp 100
 address-family ipv6 unicast
  redistribute ospfv3 Ender //千万注意在IPv6单播地址族完成引入
IOS6(config-rtr)#redistribute bgp 100 metric 2 
IOS6(config-router-af)#redistribute rip Ender //RIPng引入到BGP的单播地址族

router bgp 100
address-family ipv6 unicast
  redistribute ospfv3 Ender
router ospfv3 Ender
 redistribute bgp 100

双向重分步完成之后还有问题
默认情况下IBGP路由不能引入到IGP,EBGP路由默认引入到IGP
RP/0/0/CPU0:QYT-XR2(config-bgp)#bgp redistribute-internal //在IOS XR上允许把IBGP路由引入到IGP
RP/0/0/CPU0:QYT-XR2(config-bgp)#commit

RP/0/0/CPU0:QYT-XR2#show ospfv3 database external 
Tue Jun 21 12:14:58.686 UTC

            OSPFv3 Router with ID (22.1.1.1) (Process ID Ender)

            Type-5 AS External Link States

  LS age: 5
  LS Type: AS External Link
  Link State ID: 0
  Advertising Router: 22.1.1.1
  LS Seq Number: 80000001
  Checksum: 0x678c
  Length: 44
  Prefix Address: 2055::5
  Prefix Length: 128, Options: None, Priority: Critical
  Metric Type: 2 (Larger than any link state path)
  Metric: 1 
  External Route Tag: 0
数据包的转发:
XE4# traceroute 2055::5 
Type escape sequence to abort.
Tracing the route to 2055::5

  1 2024::2 178 msec 12 msec 13 msec
  2  *  *  * 
  3 ::FFFF:13.1.1.3 [MPLS: Labels 300/607 Exp 0] 44 msec 88 msec 80 msec
  4 2056::6 [MPLS: Label 607 Exp 0] 56 msec 37 msec 39 msec //标签607为内层的IPv6单播的标签(多协议BGP分发的)
  5 2056::5 44 msec 76 msec 44 msec

出口PE把内层标签通过MP-BGP更新到入口PE,而入口PE更关心外层标签
RP/0/0/CPU0:QYT-XR2#show bgp ipv6 unicast labels 
Tue Jun 21 12:21:45.168 UTC
BGP router identifier 22.1.1.1, local AS number 100
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0800000   RD version: 8
BGP main routing table version 8
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop        Rcvd Label      Local Label
*> 2024::/64          ::              nolabel         24008           
*> 2044::4/128        fe80::f816:3eff:fe60:a8f4
                                      nolabel         24009           
*>i2055::5/128        66.1.1.1        607             nolabel   //出口PE分配的内层标签

2. 6VPE
6PE是对IPv6单播路由分发标签
6VPE是对XX分发标签:
A、ipv6单播(6PE)
B、IPv6 vrf单播路由 (128)
C、VPNv6路由 (64的RD+128的vrf=192)
答案为C而不是B
2.1 VRF对IPv6地址族的支持
vrf definition QYT
 rd 100:26
 !
 address-family ipv6
  route-target export 100:26
  route-target import 100:26
interface GigabitEthernet0/1
 vrf forwarding QYT
 no ip address
 duplex auto
 speed auto
 media-type rj45
 ipv6 address 2056::6/64
IOS XR把接口划入vrf
vrf QYT
 address-family ipv6 unicast
  import route-target
   100:26
  !
  export route-target
   100:26
  !
 !
!
interface GigabitEthernet0/0/0/1
 vrf QYT
 ipv6 address 2024::2/64
2.2 激活PE的VPNV6地址族邻居
router bgp 100
 address-family vpnv6 unicast //初始化VPNV6的地址族
 !
 neighbor 66.1.1.1
  address-family vpnv6 unicast //激活邻居
IOS6(config)#router bgp 100
IOS6(config-router)#address-family vpnv6
IOS6(config-router-af)#neighbor 22.1.1.1 activate 

IOS6#show bgp vpnv6 unicast all summary 
BGP router identifier 66.1.1.1, local AS number 100
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
22.1.1.1        4          100       6       6        1    0    0 00:00:07        0
2.3 和CE建立协议的邻居以及引入路由
IGP就双向重分步
!! IOS XR Configuration 5.3.2
router ospfv3 110
 vrf QYT
  area 0
   interface GigabitEthernet0/0/0/1
router bgp 100 
vrf QYT
  rd 100:26
  !
  address-family ipv6 unicast
   redistribute ospfv3 110
BGP默认对VPNV6路由分发标签(602)
*> 2044::4/128        fe80::f816:3eff:fe60:a8f4
                                      nolabel         24007 
总结:
在IPv4和MPLS的网络中传输原始的IPv6或者是客户的IPv6报文

3.Inter-AS MPLS VPN
多种解决方案
在ASBR之间如何更新路由和如何使得标签连续

OptionA(1)
在ASBR之间运行Back2Back的解决方案:
控制层面:在ASBR之间实施VRF,通过VRF的RT匹配收取vpnv4路由
数据转发层面:在ASBR之间采用IP转发,域内是标签转发

  评论这张
 
阅读(45)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017