注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

如何实现华为交换设备不同链路类型的切换  

2015-11-30 21:49:09|  分类: 华为技术 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
如何实现华为交换设备不同链路类型的切换 - ender.joe - 乾颐堂_安德(Ender)的博客
 
Trunk干道
一个链路上承载多个vlan流量的链路类型,本质是VLAN ID(TAG)
经典的用于交换机和交换机之间
interface GigabitEthernet0/0/23
 port link-type trunk
 port trunk allow-pass vlan 2 to 4094 ---注意允许通过的vlan列表。华为设备默认仅仅允许vlan1通过(思科默认允许所有)
dis port vlan ac
在trunk链路上分2种:TAG和UNTAG(不打tag,思科称之为native vlan)
 port trunk pvid vlan 10---即该vlan在trunk上不打TAG(等同于)
PVID仅仅针对一个vlan流量
==================================
Hybrid混合链路类型
3700
如何修改华为“麻烦”的链路类型
trunk--->hybrid
方式一、去掉trunk允许的vlan,然后修改接口类型
undo port tr all vlan 2 to 4094然后再来修改链路类型
方式二、access改为trunk
interface Ethernet0/0/23
 port link-type access
 port default vlan 10
--->
[QYT-HW-3700-Ethernet0/0/23] port default vlan 1 
稍微总结一下:如果仅仅有link-type命令可以直接改。但是如果有非默认命令就必须先去掉该默认命令或者变成默认命令(port hybrid pvid vlan 1)
实现Hybrid
interface Ethernet0/0/10
 port hybrid pvid vlan 100 ---连接PC的接口,以太帧进入交换机附加PVID 100
 port hybrid untagged vlan 2 to 3 100 ---数据包从该接口发出去,允许去掉vlan2、3、100的tag,变成原始以太帧发给PC
PC3-->PC1,在sw2的10口附加PVID100,那么SW1会收到VLAN ID为100的帧
PC1-->PC3,在sw1的10口附加PVID 2,那么sw2会收到VLAN ID为2的帧
------------------------------
interface Ethernet0/0/10
 port hybrid pvid vlan 100
 port hybrid untagged vlan 2 to 3 100
!如上配置如何变成access到vlan 10的配置
[SW2-Ethernet0/0/10]un  port hybrid untagged vlan 2 to 3 100 ---去掉untagged命令
[SW2-Ethernet0/0/10]port link-t access                     
Error: Please renew the default configurations.
[SW2-Ethernet0/0/10]dis th
#
interface Ethernet0/0/10
 port hybrid pvid vlan 100
#
return
[SW2-Ethernet0/0/10]
Nov 30 2015 21:03:31-08:00 SW2 DS/4/DATASYNC_CFGCHANGE:OID 1.3.6.1.4.1.2011.5.25.191.3.1 configurations have been changed. The current change number is 9, the change loop count is 0, and the maximum number of records is 4095.
[SW2-Ethernet0/0/10]
[SW2-Ethernet0/0/10]port hybrid pvid vlan 1 ---hybrid变为默认的PVID1,然后才可以修改 
-----------------
Mux VLAN(等同于思科的私有vlan)
基于如下场景:1)节约IP子网和地址 2)数据隔离和安全性
MUX vlan:
主vlan
辅助vlan(从vlan):隔离vlan(只能和主vlan通信。同一个隔离型vlan内的主机也不能通信)和组(group,可以和同组以及主vlan通信,不能和其他group vlan和隔离vlan通信)vlan
实验:
vlan10为主vlan
vlan2为隔离型vlan(isolate)
vlan3为group vlan(community)
1)AR2的8口放到主vlan
vlan 10
 mux-vlan
 subordinate separate 2
 subordinate group 3
interface Ethernet0/0/10
 port link-type access
 port default vlan 10
 port mux-vlan enable
AR1的4口放到任何类型的从vlan,都可以和主vlan通信
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 2
 port mux-vlan enable vlan 2 ---隔离型可以和主vlan通信
#
return
[LSW1-GigabitEthernet0/0/10]
interface GigabitEthernet0/0/10
 port link-type access
 port default vlan 3
 port mux-vlan enable ---group型可以和主vlan通信
--------------------------
隔离型和group型不能通信
SW2:
interface Ethernet0/0/10
 port link-type access
 port default vlan 2 ---此时隔离型和gourp型不可通信
 port mux-vlan enable
-------------------------
不同group vlan之间能否通信?不能!
vlan 5(group vlan)
[LSW1]display mux-vlan  
Principal Subordinate Type         Interface  
-----------------------------------------------------------------------------
10        -           principal   
10        2           separate    
10        3           group        GE0/0/10            
10        5           group       
------------------------------------------------------------------------
LAB作业:实现mux vlan(考试题目)


  评论这张
 
阅读(167)| 评论(0)
推荐 转载

历史上的今天

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017