注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

多协议BGP对ipv6的支持以及ipv4向ipv6过渡技术  

2015-01-28 13:28:23|  分类: 安德的IPv6视频和 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
多协议BGP对ipv6的支持以及ipv4向ipv6过渡技术 - ender.joe - 乾颐堂_安德(Ender)的博客
 
MP-bgp,不用单独的开启IPv6的一个单独的协议
仅仅是激活ipv6地址族而已
 no bgp default ipv4-unicast(关掉BGP默认承载IPv4单播的能力):
BGP默认仅仅支持ipv4地址族,如果不想建立ipv4邻居,不想更新ipv4路由,仅仅想建立ipv6邻居,更新ipv6路由
既有ipv4也有ipv6地址族(双栈技术),在ipv4地址族和ipv6地址族相应激活即可

在R2和R4上建立MP-IBGP:
R4#ping 2022::2 source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2022::2, timeout is 2 seconds:
Packet sent with a source address of 2044::4
!!!!!
R4的MP-BGP的配置:
router bgp 21
 bgp log-neighbor-changes
 bgp confederation identifier 200
 bgp confederation peers 20 
 neighbor 2022::2 remote-as 20
 neighbor 2022::2 ebgp-multihop 255
 neighbor 2022::2 update-source Loopback0
 neighbor 33.1.1.1 remote-as 21
 neighbor 33.1.1.1 update-source Loopback0
 neighbor 45.1.1.5 remote-as 300
 !
 address-family ipv4
  no neighbor 2022::2 activate
  neighbor 33.1.1.1 activate
  neighbor 33.1.1.1 next-hop-self
  neighbor 45.1.1.5 activate
 exit-address-family
 !
 address-family ipv6
  neighbor 2022::2 activate
 exit-address-family
show bgp ipv6 unicast summary 
BGP router identifier 44.1.1.1, local AS number 21
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2022::2         4           20       6       6        1    0    0 00:02:08        0
最常用的方式:
no bgp default ipv4-unicast--该命令一定用
在对应的IPv4/ipv6地址族做单独的激活:
 address-family ipv6
  neighbor 2022::2 activate
====================================
在ipv6地址族下激活ipv4邻居的问题:
1、会出现嵌入式ipv6地址(6VPE/6PE)
 *   2022::2/128      ::FFFF:45.1.1.4                        0 200 i
 *   2044::4/128      ::FFFF:45.1.1.4          0             0 200 i
2、下一跳问题
在路由表中没有出现::FFFF:45.1.1.4所在的网络
用route-map在出方向修改下一跳为一个可用的全局单播地址
router bgp 200
  neighbor 45.1.1.5 route-map NH out
route-map NH permit 10
 set ipv6 next-hop 2045::4
问题A、入方向如何?
 B、修改为link-local地址如何?

除了VPN地址族不可以
========================
ipv4向ipv6的过渡技术(隧道技术)
双栈技术通常ipv4和ipv6相互不干扰
(6VPE中会有影响)
1、GRE隧道支持所有的路由协议包括IPv6的协议
interface Tunnel0---协议47
 no ip address
 ipv6 address 2024::2/64
 ipv6 ospf 110 area 0
 tunnel source Loopback0
 tunnel destination 44.1.1.1
2IPv6手工隧道
interface Tunnel0
 no ip address
 ipv6 address 2024::2/64
 ipv6 ospf 110 area 0
 tunnel source Loopback0
 tunnel mode ipv6ip---协议41
 tunnel destination 44.1.1.1
3、6to4自动隧道有固定的格式,不支持动态路由协议
2002开头,接下来32位是IPv4演变而来的
C0A8
99=63
1=01而不能写成2002:c0a8:6301
A、不需要目的
B、换算(ipv4换算成ipv6地址)
C、不支持动态路由协议,只能采用静态
interface Tunnel0
 no ip address
 no ip redirects
 ipv6 address 2002:2C01:101::4/64
 ipv6 enable
 tunnel source Loopback0
 tunnel mode ipv6ip 6to4---自动隧道的模式
ipv6 route 2002::/16 Tunnel0---不要下一跳
更迭:
ipv6 route 2002::/16 Tunnel0---明细去一个出接口的隧道
ipv6 route ::/0 2002:1601:101::2---去往默认是对端的tunnel地址
OSPF和eigrp下放默认路由没有任何问题
实验证明:
ipv6的bgp地址族,针对ipv4激活的邻居下放默认路由失败,全局单播的ipv6可以
作业:
1和2运行ospfv3,2到4是自动隧道,4和5之间运行mp-bgp下放默认路由
R5#ping 2011::1  source lo0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2011::1, timeout is 2 seconds:
Packet sent with a source address of 2055::5
!!!!!

乾颐堂安德








  评论这张
 
阅读(173)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017