注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

熟悉route-map的配置以及修改eigrp的管理距离时的注意事项/PBR  

2015-01-15 15:35:53|  分类: 安德的路由视频和 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
针对24.1.1.0/24网络在R1上重分布到eigrp的时候
过滤掉了24.1.1.0,那么此时R3去往24.1.1.0网络的
数据包选择R4

TAG字段,外部路由特有的字段,内部路由没有该字段
,控制手段,一个新的参数:
access-list 24 permit 22.1.1.1
router ei 90
 redistribute ospf 110 metric 1000 10 255 1 1500 route-map Tag
route-map Tag permit 10
 match ip address 24
 set tag 24
route-map Tag permit 11

针对tag24的路由,在R3上拒绝接收:
router ei 90
 distribute-list route-map TAG in Ethernet0/2
route-map TAG deny 10
 match tag 24
route-map TAG permit 20---不要忘记per 20

同一个设备上的不同进程或者AS数据库是不同的,自然
也就无法学习到路由。同一个协议也可以相互重分布
做在有次优路由的设备上
作业1#####
讨论OSPF的方式修改AD优化路由(33.1.2.1)
R1从R3得到的AD值是170,从R4-->R2-->R1的AD是110
所以R1有次优
router ospf 110
 router-id 11.1.1.1
 distance 180 44.1.1.1 0.0.0.0 44---修改来在
ASBR 44.1.1.1的AD次于来自R3的171 的AD。精确
的修改方式

因为R1从eigrp得到路由表(重要的前提),此时更新
到R4(OSPF)AD是110
OSPF修改AD的另外一种方式(不精确的粗犷的方式)
===============================
router ospf 110
 router-id 44.1.1.1
 redistribute eigrp 90 subnets
 distance ospf external 180---修改外部路由的AD
用EIGRP修改AD

R1修改eigrp的AD为108,选择的更新源是?
更新源:
33.1.2.1(as100)√√
33.1.1.1(as90) 
10.1.1.3(直连接口)√√√

 distance 108 10.1.1.3 0.0.0.0 44
这种方式针对eigrp和bgp不生效!!!
只能用粗犷的方式去修改
最终方案:尽量用OSPF的精确的方式去修改AD!!

=================================
PBR!policy based routing
第一种理解方式:凌驾于路由表基础之上的,完全通过
CPU就计算的方式
第二种理解方式即BGP的策略
一定意义上是QOS里边的传统的命令行直接干预数据包的转发!!!
和数据源有关的一个技术!

Gateway of last resort is not set

      12.0.0.0/24 is subnetted, 1 subnets
D EX     12.1.1.0 [170/2588160] via 10.1.1.4, 00:15:19, Ethernet0/2
                  [170/2588160] via 10.1.1.1, 00:15:19, Ethernet0/2
      22.0.0.0/32 is subnetted, 1 subnets
D EX     22.1.1.1 [170/2588160] via 10.1.1.1, 00:15:19, Ethernet0/2
      24.0.0.0/24 is subnetted, 1 subnets
D EX     24.1.1.0 [170/2588160] via 10.1.1.4, 00:15:19, Ethernet0/2
                  [170/2588160] via 10.1.1.1, 00:15:19, Ethernet0/2
R3#trac
R3#traceroute 22.1.1.1
Type escape sequence to abort.
Tracing the route to 22.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.1 1 msec 0 msec 0 msec
  2 12.1.1.2 11 msec 10 msec * 
R3#
与之相关的技术:
1、如何匹配报文
 ACL/报文大小
2、route-map
 匹配到条件设置出接口或者下一跳
3、应用
1)应用到转发流量的入接口
2)本地(本路由器)发起的流量
作业2%###
第一种应用:流经R1的应用
ip access-list extended PBR
 permit ip host 10.1.1.3 host 22.1.1.1
route-map PBR permit 10
 match ip address PBR
 set ip next-hop 10.1.1.4
interface Ethernet0/2
 ip address 10.1.1.1 255.255.255.0
 ip policy route-map PBR

R3#traceroute 22.1.1.1
Type escape sequence to abort.
Tracing the route to 22.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.1 1 msec 4 msec 2 msec
  2 10.1.1.4 1 msec 2 msec 0 msec
  3 24.1.1.2 11 msec 11 msec * 
debug ip policy PBR
验证:
*Jan 13 09:53:43.284: IP: Ethernet0/2 to Ethernet0/2 10.1.1.4
*Jan 13 09:53:43.285: IP: s=10.1.1.3 (Ethernet0/2), d=22.1.1.1
R1#, len 28, FIB policy match
*Jan 13 09:53:43.285: IP: s=10.1.1.3 (Ethernet0/2), d=22.1.1.1, len 28, PBR Counted
*Jan 13 09:53:43.285: IP: s=10.1.1.3 (Ethernet0/2), d=22.1.1.1, g=10.1.1.4, len 28, FIB policy routed
*Jan 13 09:53:43.285: IP: s=10.1.1.3 (Ethernet0/2), d=22.1.1.1, len 28, policy match
*Jan 13 09:53:43.285: IP: route map PBR, item 10, permit
*Jan 13 09:53:43.285: IP: s=10.1.1.3 (Ethernet0/2), d=22.1.1.1 (Ethernet0/2), len 28, policy routed
*Jan 13 09:53:43.285: IP: Ethernet0/2 to Ethernet0/2 10.1.1.4
*Jan 13 09:53:43.286: IP: s=10.1.1.3 (Ethernet0/2), d=255.255.255.255, len 67, policy rejected -- normal forwarding

第二种应用R1本地发起的流量
ip access-list extended PBR
 permit ip host 10.1.1.3 host 22.1.1.1
route-map PBR permit 10
 match ip address PBR
 set ip next-hop 10.1.1.4
interface Ethernet0/2
 ip address 10.1.1.1 255.255.255.0
 ip policy route-map PBR
R3(config)#ip local policy route-map PBR 
验证:
R3#traceroute 22.1.1.1
Type escape sequence to abort.
Tracing the route to 22.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 10.1.1.4 1 msec 1 msec 1 msec
  2 24.1.1.2 10 msec 11 msec * 
R3#sh access-lists PBR
Extended IP access list PBR
    10 permit ip host 10.1.1.3 host 22.1.1.1 (11 matches)
ACL通常只对经过的或者到达本设备的流量有效,但是该场景本地发起的生效
=================================
TCP/IP路由技术第二卷
CIDR--->BGP
BGP是一种DV协议,但有时称之为路径向量协议(AS-PATH属性)
BGP有一种度量值称之为AS-PATH。每经过一个AS
AS-by-AS的协议 VS router-by-router
BGP,本身就是一个多协议的BGP(MP-BGP,支持IPv4地址族、IPv6地址族)
ipv6的mask---64


















  评论这张
 
阅读(638)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017