注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

Yeslab安德技术文档:IPv6-6-Eigrp for IPv6  

2013-03-08 10:16:31|  分类: 安德的IPv6视频和 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

IPv6-6-Eigrp for IPv6

目录

IPv6-6-Eigrp for IPv6. 1

一、理论支持和实验目的... 1

二、拓扑描述... 1

三、实验步骤... 2

1、建立简单的eigrp for ipv6邻居... 2

2Eigrp for IPv6认证... 3

3、修改eigrp for ipv6其他一些参数... 3

 

 

一、理论支持和实验目的

Eigrp for IPv6在本质上和Eigrp for IPv4没有区别,依旧采用DUAL算法,采用组播更新,触发更新

IPv6 Eigrp直接配置在接口上,该特性的结果为接口可以没有IPv6全局单播地址,Eigrp for IPv6没有网络状态. Eigrp for IPv6需要一个RID,默认情况下eigrp进程是关闭的,需要在进程下做no shutdown.

二、拓扑描述

如图所示,每个设备上的地址设计为20xy::x/64如图R3连接R4的接口地址为2034::3/64,每个设备的环回口为20XX::X/128,比如R1的环回口为2011::1/128

Yeslab安德技术文档:IPv6-6-Eigrp for IPv6 - ender.joe - Yeslab_安德(Ender)的博客
 

 

三、实验步骤

本实验需15.0以上IOS

1、建立简单的eigrp for ipv6邻居

R1(config)#ipv6 unicast-routing

R1(config)#interface serial 2/0

R1(config-if)#ipv6 enable---R1上不设置IPv6全局单播地址,仅仅生成link-local地址,和OSPFv3同,不在依赖“子网”概念就能通过link-local地址在链路上交换数据包

R1(config-if)#ipv6 eigrp 100---接口使能eigrp for IPv6

R1(config)#ipv6 router eigrp 100---EIgrp进程配置命令

R1(config-rtr)#no shut---默认情况下eigrp进程是关闭的,需要手动打开,此处并没有设置eigrp RID,默认情况下会选择一个环回口作为RID,推荐手动设备EIGRP RID

!

R2的配置:

interface Serial2/0

 no ip address

 ipv6 address 2012::2/64

 ipv6 eigrp 100

R2(config)#ipv6 router eigrp 100

R2(config-rtr)#no shut

R2(config-rtr)#eigrp router-id ?

  A.B.C.D  EIGRP Router-ID in IP address format

 

R2(config-rtr)#eigrp router-id 2.2.2.2

验证:

R1#show ipv6 eigrp neighbors ---邻居已经建立,而且其中的参数含义和IPv4相同,地址为link-local地址

EIGRP-IPv6 Neighbors for AS(100)

H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq

                                                   (sec)         (ms)       Cnt Num

0   Link-local address:     Se2/0                    11 00:38:07   44   264  0  2

    FE80::A8BB:CCFF:FE00:200

!

接下来把两个设备的环回口0启用eigrpR2为例:

interface Loopback0

ipv6 address 2022::2/128

 ipv6 eigrp 100

查看路由:

R1#sh ipv6 route eigrp

IPv6 Routing Table - default - 16 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

       l - LISP

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D   2012::/64 [90/2681856]

     via FE80::A8BB:CCFF:FE00:200, Serial2/0---通过下一跳(link-local地址)得到了2012::/64的路由,因为R1上没有该全局路由

D   2022::2/128 [90/2297856]

     via FE80::A8BB:CCFF:FE00:200, Serial2/0

2Eigrp for IPv6认证

R1(config)#key chain Ender---定义key chain,本地意义

R1(config-keychain)#key 1---定义Key ID,两端相同

R1(config-keychain-key)#key-string Yeslab---钥匙链一定要相同

!

接口开始认证以及调用key-chain

R1(config)#int s2/0

R1(config-if)#ipv6 authentication mode eigrp 100 md5---开启MD5认证

*Mar  5 13:47:23.210: %DUAL-5-NBRCHANGE: EIGRP-IPv6 100: Neighbor FE80::A8BB:CCFF:FE00:200 (Serial2/0) is down: authentication mode changed

R1(config-if)#ipv6 authentication key-chain eigrp 100 Ender---调用key chain

R2的配置(两端的key chain 名不一致):

key chain Test

 key 1

  key-string Yeslab

interface Serial2/0

 no ip address

 ipv6 address 2012::2/64

 ipv6 enable

 ipv6 eigrp 100

 ipv6 authentication mode eigrp 100 md5

 ipv6 authentication key-chain eigrp 100 Test

3、修改eigrp for ipv6其他一些参数

A)汇总路由,依旧采用在接口下汇总的方式(不存在IPv6ABC类路IP的分类,所以没有自动汇总)

R2(config)#int s2/0

R2(config-if)#ipv6 summary-address eigrp 100 2022::/48

R2#

*Mar  5 13:55:41.566: %DUAL-5-NBRCHANGE: EIGRP-IPv6 100: Neighbor FE80::A8BB:CCFF:FE00:100 (Serial2/0) is resync: summary configured

查看R1

R1#sh ipv6 route ei

IPv6 Routing Table - default - 16 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

       l - LISP

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D   2012::/64 [90/2681856]

     via FE80::A8BB:CCFF:FE00:200, Serial2/0

D   2022::/48 [90/2297856]---已经汇总成了48位路由

     via FE80::A8BB:CCFF:FE00:200, Serial2/0

B)重分步以及修改内部和外部路由的AD

R2上新建立环回口重分步到Eigrp

R2(config)#int lo 100

R2(config-if)#ipv6 address 2222::2/64

!

R2(config)#route-map L2 permit 10

R2(config-route-map)#match interface lo 100

!

R2(config)#ipv6 router eigrp 100

R2(config-rtr)#redistribute connected  route-map L2

R1:

R1(config)#ipv6 router eigrp 100

R1(config-rtr)#distance eigrp 89 169
查看路由:

R1#show ipv6 route eigrp

IPv6 Routing Table - default - 17 entries

Codes: C - Connected, L - Local, S - Static, U - Per-user Static route

       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP

       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea

       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO

       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect

       l - LISP

       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2

       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2

D   2012::/64 [89/2681856]

     via FE80::A8BB:CCFF:FE00:200, Serial2/0

D   2022::/48 [89/2297856]---内部路由的AD值为89

     via FE80::A8BB:CCFF:FE00:200, Serial2/0

EX  2222::/64 [169/2297856]---外部路由AD值为169

     via FE80::A8BB:CCFF:FE00:200, Serial2/0

CEigrp for IPv6 StubIPv4相同,抑制查询

R1(config-rtr)#eigrp stub

其他一下参数和IPv4基本相同,不再一一赘述。命令列表如下:

R1(config-rtr)#?

  default            Set a command to its defaults

  default-metric     Set metric of redistributed routes

  distance           Define an administrative distance

  distribute-list    Filter networks in routing updates

  eigrp              EIGRP specific commands

  exit               Exit from IPv6 routing protocol configuration mode

  maximum-paths      Forward packets over multiple paths

  metric             Modify metrics and parameters for advertisement

  neighbor           Specify a neighbor router

  no                 Negate a command or set its defaults

  passive-interface  Suppress routing updates on an interface

  redistribute       Redistribute IPv6 prefixes from another routing protocol

  shutdown           Shutdown topology

  summary-metric     Specify summary to apply metric/filtering

  timers             Adjust topology specific timers

  variance           Control load balancing variance

 

R1(config-if)#ipv6 hello-interval eigrp 100 4---修改hello间隔

R1(config-if)#ipv6 hold-time eigrp 100 14---修改holdtime

 

实验完成

欢迎大家继续关注Ender的文档以及更多视频:

http://www.yeslab.net/ender/

http://ender.joe.blog.163.com/

  评论这张
 
阅读(448)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017