注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

OSPF forward address理论和实验  

2012-12-03 18:03:43|  分类: 安德的路由视频和 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

OSPF forward address理论和实验 - ender.joe - Yeslab_安德(Ender)的博客
 

实验目的:了解OSPF Forward address

关于转发地址(forward address,五类或者七类LSA中的一个必选字段):其为ASBR通告的外部路由的重要一环,作用为通知ospf内部的路由器如何更快捷的到达外部路由的下一跳地址.如果ospfO或者OIA的路由表内不能得到去往forward address的路由,那么将不装载外部路由

 

第一种情况:NSSA区域的Forward Address

步骤一、

配置area1 NSSA区域,注意R1R2的接口被放进了OSPF,而R4没有运行ospf

R1

接口配置:

interface FastEthernet1/0

 ip address 10.1.1.1 255.255.255.0

 ip ospf 110 area 1

进程配置:

router ospf 110

 router-id 1.1.1.1

 area 1 nssa

 

R2

接口配置

interface FastEthernet1/0

 ip address 10.1.1.2 255.255.255.0

 ip ospf 110 area 1

进程配置

router ospf 110

 router-id 2.2.2.2

 area 1 nssa

每个设备的环回口都放进了ospf,在此不在赘述

R1R3运行在area0

 

验证我们的邻居关系以及路由情况:

R1#sh ip ospf neighbor ----邻居关系正常

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

3.3.3.3           0   FULL/  -        00:00:36    13.1.1.3        Serial0/3

2.2.2.2           1   FULL/BDR        00:00:30    10.1.1.2        FastEthernet1/0

 

R1#sh ip route ospf ----路由正常

     33.0.0.0/32 is subnetted, 1 subnets

O       33.1.1.1 [110/65] via 13.1.1.3, 00:16:19, Serial0/3

 

步骤二、查看NSSAForward Address

R2上新建立Loopback1,并把其重分步进ospf

interface Loopback1

 ip address 122.1.1.1 255.255.255.0

进程配置:

router ospf 110

 redistribute connected subnets route-map LO1

 

route-map配置:

route-map LO1 permit 10

 match interface Loopback1

 

R3上已经可以看到OE2的外部路由:

R3#sh ip route ospf

     10.0.0.0/24 is subnetted, 1 subnets

O IA    10.1.1.0 [110/65] via 13.1.1.1, 00:13:13, Serial0/3

     122.0.0.0/24 is subnetted, 1 subnets

O E2    122.1.1.0 [110/20] via 13.1.1.1, 00:13:08, Serial0/3

 

R3#sh ip ospf database external

 

            OSPF Router with ID (3.3.3.3) (Process ID 110)

 

                Type-5 AS External Link States

 

  Routing Bit Set on this LSA

  LS age: 1125

  Options: (No TOS-capability, DC)

  LS Type: AS External Link

  Link State ID: 122.1.1.0 (External Network Number )

  Advertising Router: 1.1.1.1

  LS Seq Number: 80000001

  Checksum: 0x1EF3

  Length: 36

  Network Mask: /24

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 20

        Forward Address: 10.1.1.2

        External Route Tag: 0

R1为区域0和区域2ABR,它把7LSA转换成5LSA,然后把5LSA通告到其他ospf区域,所以通过查看R1自身产生的5LSA可以验证:

R1#sh ip os database external self-originate     

 

            OSPF Router with ID (1.1.1.1) (Process ID 110)

 

                Type-5 AS External Link States

 

  LS age: 1102

  Options: (No TOS-capability, DC)

  LS Type: AS External Link

  Link State ID: 122.1.1.0 (External Network Number )

  Advertising Router: 1.1.1.1

  LS Seq Number: 80000001

  Checksum: 0x1EF3

  Length: 36

  Network Mask: /24

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 20

        Forward Address: 10.1.1.2

        External Route Tag: 0

ospf区域内的设备上Forward Address的路由必须可达才可通过它到达外部路由,否则外部路由不可达。举例说明:

R3(config)#ip route 10.1.1.0 255.255.255.0 null 0----R3上增加一条去往forward address的静态路由,使得该路由不可达,我们来验证外部路由的情况

R3#debug ip packet detail ----开启debug消息

IP packet debugging is on (detailed)

R3#ping 122.1.1.1        

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 122.1.1.1, timeout is 2 seconds:

 

*Mar  1 00:30:22.939: IP: s=13.1.1.3 (local), d=224.0.0.5 (Serial0/3), len 80, sending broad/multicast, proto=89

*Mar  1 00:30:23.139: IP: s=33.1.1.1 (local), d=122.1.1.1, len 100, unroutable---不可路由,虽然此时路由表中依旧存在该外部路由。

 

第二种情况:非NSSA区域的Forward Address

去掉之前的区域1R1R2)的NSSA配置

R1(config)#router os 110

R1(config-router)#no area 1 nssa

 

通常在非NSSA情况下,forward address0.0.0.0,去往外部路由只需要通过ASBR得知即可,如R1上:

R1#sh ip ospf border-routers

 

OSPF Process 110 internal Routing Table

 

Codes: i - Intra-area route, I - Inter-area route

 

i 2.2.2.2 [1] via 10.1.1.2, FastEthernet1/0, ASBR, Area 1, SPF 10

R1#show ip ospf database external

 

            OSPF Router with ID (1.1.1.1) (Process ID 110)

 

                Type-5 AS External Link States

 

  Routing Bit Set on this LSA

  LS age: 451

  Options: (No TOS-capability, DC)

  LS Type: AS External Link

  Link State ID: 122.1.1.0 (External Network Number )

  Advertising Router: 2.2.2.2

  LS Seq Number: 80000001

  Checksum: 0x5CBF

  Length: 36

  Network Mask: /24

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 20

        Forward Address: 0.0.0.0

        External Route Tag: 0

 

然后在某些情况下,非NSSA区域也可产生非0forward address

步骤一、现在开始用到我们的R4,开启R4F1/0R4运行eigrp协议,其环回口也通告进eigrp,并且R2F1/0通告进eigrp。也就是说R2R4之间建立eigrp邻居,同时R2R4上把eigrp重分步进OSPF。当然R1F1/0R2F1/0依旧在OSPF区域

R2

router ospf 110

 router-id 2.2.2.2

 redistribute eigrp 90 subnets

router eigrp 90

 network 0.0.0.0

 no auto-summary

 R4

router eigrp 90

 network 10.1.1.4 0.0.0.0

 network 44.1.1.1 0.0.0.0

 no auto-summary

 

查看我们的路由

R1#sh ip route ospf

     33.0.0.0/32 is subnetted, 1 subnets

O       33.1.1.1 [110/65] via 13.1.1.3, 00:39:56, Serial0/3

     122.0.0.0/24 is subnetted, 1 subnets

O E2    122.1.1.0 [110/20] via 10.1.1.2, 00:01:22, FastEthernet1/0

     44.0.0.0/24 is subnetted, 1 subnets

O E2    44.1.1.0 [110/20] via 10.1.1.4, 00:01:22, FastEthernet1/0----R4的环回口从R4直接学习到,而不是通过ASBRR2学习到,这是一种路由优化,目的是为了到达外部路由44.1.1.0更加优化,可以直接到达R4,而不用通过R2再到达R4,因为现在R1R2R4在一个广播网络

来查看我们的Forward Address

R1#sh ip ospf database external

 

            OSPF Router with ID (1.1.1.1) (Process ID 110)

 

                Type-5 AS External Link States

 

  Routing Bit Set on this LSA

  LS age: 510

  Options: (No TOS-capability, DC)

  LS Type: AS External Link

  Link State ID: 44.1.1.0 (External Network Number )

  Advertising Router: 2.2.2.2

  LS Seq Number: 80000001

  Checksum: 0x1644

  Length: 36

  Network Mask: /24

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 20

        Forward Address: 10.1.1.4----去往44.1.1.0的外部路由通过该Forward直接到达

        External Route Tag: 0

 

  Routing Bit Set on this LSA

  LS age: 787

  Options: (No TOS-capability, DC)

  LS Type: AS External Link

  Link State ID: 122.1.1.0 (External Network Number )

  Advertising Router: 2.2.2.2

  LS Seq Number: 80000002

  Checksum: 0x5AC0

  Length: 36

  Network Mask: /24

        Metric Type: 2 (Larger than any link state path)

        TOS: 0

        Metric: 20

        Forward Address: 0.0.0.0----到达122.1.1.0的外部路由依旧去往ASBR 2.2.2.2

        External Route Tag: 0

 

总结:Forward Adress0的情况要满足一下条件,OSPFASBR的下一跳上使能(R2F1/0),并且ASBR的下一跳接口没有passive,同时该接口不是点到点或者点到多点网络类型

  评论这张
 
阅读(2276)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017