注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

乾颐堂_安德(Ender)的博客

学无前后达者为先,此博客是一个有态度网络技术共享平台,共享给大家更多知识和经验

 
 
 

日志

 
 
关于我

Ender“老湿”:双CCIE(R&S CCIE、ISP CCIE),思科认证讲师#34XXX,HCIE v2.0第一人。毕业于东北大学电子商务专业。在原公司及其他企业参与的重点项目和培训有: R&S CCIE专题课 SP CCIE专题课 思科支蜀援川项目 索尼中国(无锡)NP课程 能在这里找到我:QQ群106111081 我的微博:weibo.com/enderjoe

网易考拉推荐

安德CCIE技术文档OSPF在帧中继环境下的三种二层接口类型  

2012-11-29 11:44:25|  分类: 安德的路由视频和 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |

OSPF over Frame-relay(三种接口类型) full-mesh

拓扑描述如下图,其中301103等代表DLCI

安德CCIE技术文档OSPF在帧中继环境下的三种二层接口类型 - ender.joe - Yeslab_安德(Ender)的博客
 

本文探讨在帧中继环境下的物理接口类型在ospf中的应用,而不是ospf的网络类型,当然每一种物理接口的类型有默认的ospf的网络类型

总体上说,OSPF over frame-relay的物理接口类型可以分为三种:

1、物理接口

2、点到点子接口

3、多点子接口

 

第一种情况 物理接口

步骤1

R2模拟frame-relay交换机,帧中继的配置不再赘述,配置如下:

R2frame-relay switch

 

frame-relay switching

 

interface Serial0/0

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 no dce-terminal-timing-enable

 frame-relay intf-type dce

 frame-relay route 103 interface Serial0/1 301

 frame-relay route 104 interface Serial0/2 401

 

interface Serial0/1

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 no dce-terminal-timing-enable

 frame-relay intf-type dce

 frame-relay route 301 interface Serial0/0 103

 frame-relay route 304 interface Serial0/2 403

 

interface Serial0/2

 no ip address

 encapsulation frame-relay

 serial restart-delay 0

 no dce-terminal-timing-enable

 frame-relay intf-type dce

 frame-relay route 401 interface Serial0/0 104

 frame-relay route 403 interface Serial0/1 304

验证命令:

R2#sh frame-relay route

Input Intf      Input Dlci      Output Intf     Output Dlci     Status

Serial0/0       103             Serial0/1       301             active

Serial0/0       104             Serial0/2       401             active

Serial0/1       301             Serial0/0       103             active

Serial0/1       304             Serial0/2       403             active

Serial0/2       401             Serial0/0       104             active

Serial0/2       403             Serial0/1       304             active

 

R1R3R4的物理接口地址分别为10.1.1.110.1.1.310.1.1.4

R1为例:

interface Serial0/0

 ip address 10.1.1.1 255.255.255.0

 encapsulation frame-relay

 frame-relay map ip 10.1.1.3 103 broadcast

 frame-relay map ip 10.1.1.4 104 broadcast

 no frame-relay inverse-arp

 

验证命令:

R1#sh frame-relay map

Serial0/0 (up): ip 10.1.1.3 dlci 103(0x67,0x1870), static,

              broadcast,

              CISCO, status defined, active

Serial0/0 (up): ip 10.1.1.4 dlci 104(0x68,0x1880), static,

              broadcast,

              CISCO, status defined, active

请确保直连是可以ping通的,并保证静态map配置了Broadcast关键字,允许组播和广播通过帧中继

R1#ping 10.1.1.3

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.3, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/40/76 ms

R1#ping 10.1.1.4

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/28/56 ms

步骤2

OSPFNBMA环境下不会自动发现邻居,需要手工制定,注意只需要在一端指定就好(通常在DR上指定邻居)

R1上的配置:

router ospf 110

 log-adjacency-changes

 network 10.1.1.0 0.0.0.255 area 0

 network 11.1.1.1 0.0.0.0 area 0

 neighbor 10.1.1.3

 neighbor 10.1.1.4

R1#sh ip ospf neighbor ----会出现一个特定的NBMA环境下的ATTEMPT状态,通常会等待较长时间(dead time)才能建立邻居

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

N/A               0   ATTEMPT/DROTHER 00:01:31    10.1.1.3        Serial0/0

N/A               0   ATTEMPT/DROTHER 00:01:31    10.1.1.4        Serial0/0

 

分析:NBMA需要有DRBDRDRother路由器只和DRBDR交换SLA,我们需要在指定neighbors的设备上设定为DR

我们先来看不理想的情况:

R3#sh ip route ospf

     11.0.0.0/32 is subnetted, 1 subnets

O       11.1.1.1 [110/65] via 10.1.1.1, 00:05:13, Serial0/1

R3#sh ip ospf neighbor ---R3本身是DR,但我们希望R1作为DR

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

10.1.1.1          1   FULL/BDR        00:01:41    10.1.1.1        Serial0/1

R3并没有得到完整的ospf的路由,缺失了R4的环回口路由

 

步骤3、控制DR以得到完整的路由

R3R4上把优先级降为0,保证R1成为DR

R3(config)#int s0/1

R3(config-if)#ip ospf priority 0

在邻居起来后:

R3#sh ip route ospf

     11.0.0.0/32 is subnetted, 1 subnets

O       11.1.1.1 [110/65] via 10.1.1.1, 00:00:13, Serial0/1

     44.0.0.0/32 is subnetted, 1 subnets

O       44.1.1.1 [110/65] via 10.1.1.4, 00:00:13, Serial0/1----观察路由,去往R4的环回口下一跳为10.1.1.4的直连接口,而R3是有去往10.1.1.4DLCI的,所以全互联情况下没有问题,而如果在部分互联的情况下,举例:我们去掉R3去往R4DLCIR4去往R3DLCI,会造成二层封装失败。我们来演示一下:

R3(config)#int s0/1

R3(config-if)#no frame-relay map ip 10.1.1.4 304 broadcast

 

R4(config)#int s0/2

R4(config-if)#no frame-relay map ip 10.1.1.3 403 broadcast

 

R3#ping 10.1.1.4----虽然有路由但是包不通

 

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.4, timeout is 2 seconds:

....

Success rate is 0 percent (0/4)

 

总结:帧中继环境下物理接口时默认为NBMA的网络类型,需要DR的选举,Hello间隔30秒,dead时间120秒。在DR设备上手工指定邻居即可

辅以接口佐证:

R1#sh ip ospf interface s0/0

Serial0/0 is up, line protocol is up

  Internet Address 10.1.1.1/24, Area 0

  Process ID 110, Router ID 10.1.1.1, Network Type NON_BROADCAST, Cost: 64

  Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 10.1.1.1, Interface address 10.1.1.1

  No backup designated router on this network

  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

 

推荐全互联的情况下把网络类型修改成Broadcast,此时不用手工指定邻居,正常宣告即可

Broadcast的网络类型Hello间隔10秒,Dead时间40

 

第二种情况多点子接口

多点子接口完全具备所有物理接口的特点。多点子接口可以和其他两种物理接口类型,即物理接口、点到点子接口结合使用

 

步骤1、在R1上物理接口封装帧中继,开启多点子接口:

先去掉之前的物理接口下的IP地址和静态map

R1(config)#int s0/0.1 multipoint

R1(config-subif)#ip address 10.1.1.1 255.255.255.0

R1(config-subif)#frame-relay map ip 10.1.1.3 103 broadcast

R1(config-subif)#frame-relay map ip 10.1.1.4 104 broadcast

 

其他两台设备不做改变,也就是说,现在是一个多点子接口结合两个物理接口的方案

步骤2、其他配置并没有做改变

R1#sh ip ospf neighbor

 

Neighbor ID     Pri   State           Dead Time   Address         Interface

33.1.1.1          0   FULL/DROTHER    00:01:30    10.1.1.3        Serial0/0.1

10.1.1.4          0   FULL/DROTHER    00:01:59    10.1.1.4        Serial0/0.1----ospf接口变化,不再是物理接口

R1#sh ip ospf interface s0/0.1

Serial0/0.1 is up, line protocol is up

  Internet Address 10.1.1.1/24, Area 0

  Process ID 110, Router ID 10.1.1.1, Network Type NON_BROADCAST, Cost: 64

  Transmit Delay is 1 sec, State DR, Priority 1

  Designated Router (ID) 10.1.1.1, Interface address 10.1.1.1

  No backup designated router on this network

  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5

    oob-resync timeout 120

    Hello due in 00:00:14

  Supports Link-local Signaling (LLS)

  Index 2/2, flood queue length 0

  Next 0x0(0)/0x0(0)

  Last flood scan length is 1, maximum is 2

  Last flood scan time is 0 msec, maximum is 4 msec

  Neighbor Count is 2, Adjacent neighbor count is 2

    Adjacent with neighbor 33.1.1.1

    Adjacent with neighbor 10.1.1.4

  Suppress hello for 0 neighbor(s)

 

和物理接口相同,多点子接口网络类型默认是NBMA,需要DRhello时间30秒,需要手工指定邻居或者把网络类型改为Broadcast。网络类型为NBMA时依然要注意DR的位置

 

第三种情况点到点子接口

点到点子接口默认是点到点的网络类型,hello间隔为10秒,不需要DR的选举

步骤1、沿用之前的配置,在R3上开启点到点子接口

 

R3(config)#int s0/1

R3(config-if)#no ip address

R3(config-if)#no frame-relay map ip 10.1.1.1 301 broadcast

R3(config-if)#no frame-relay map ip 10.1.1.4 304 broadcast

 

R3(config)#int s0/1.3 point-to-point

R3(config-subif)#ip address 10.1.1.3 255.255.255.0

R3(config-subif)#frame-relay interface-dlci 301

 

R1#debug ip ospf events

OSPF events debugging is on

R1#

*Mar  1 04:59:57.062: OSPF: Rcv hello from 33.1.1.1 area 0 from Serial0/0.1 10.1.1.3

*Mar  1 04:59:57.066: OSPF: Mismatched hello parameters from 10.1.1.3

*Mar  1 04:59:57.070: OSPF: Dead R 40 C 120, Hello R 10 C 30  Mask R 255.255.255.0 C 255.255.255.0

 

ospf邻居并不能建立因为hello时间不一致

 

我们可以更改hello时间或者修改OSPF的网络类型来建立ospf的邻居。这里我们采取把ospf的网络类型改为Broadcast的方法

 

R1(config)#int s0/0.1

R1(config-subif)#ip ospf network broadcast

 

R3(config)#int s0/1.3

R3(config-subif)#ip ospf network broadcast

 

R4上也可以做相应的操作,但是此时我们的网络类型已经发生了变化,现在会是一种Hub-Spoke的情况,即R3R4之间是没有直连的。此时一定要注意让Hub设备也就是R1成为DR,否则课程导致路由缺失。我们会在后面讨论

  评论这张
 
阅读(976)| 评论(2)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017